summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-05-09 12:42:37 +0200
committerFelix Fietkau <nbd@nbd.name>2017-05-09 12:43:45 +0200
commitc328d1f6fe982888b5f5852423ee0a41cee3adb1 (patch)
tree112e26776ae1aae1a36b6ea2db88ed4ab1810e84
parente06e5376e1a2d70de256fe9da0ea78d2a7695a98 (diff)
downloadfirewall3-c328d1f6fe982888b5f5852423ee0a41cee3adb1.tar.gz
build: use -Wno-format-truncation instead of -Wno-error=format-truncation
Fixes build error with older gcc Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3799bc7..81928a6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,7 @@
cmake_minimum_required(VERSION 2.6)
PROJECT(firewall3 C)
-ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -Wmissing-declarations -Wno-error=format-truncation)
+ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -Wmissing-declarations -Wno-format-truncation)
SET(iptc_libs ip4tc)