summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-05-04 16:17:51 +0200
committerFelix Fietkau <nbd@nbd.name>2017-05-04 16:17:51 +0200
commit533f8345ab185d0c6f93565e68056edb093e3c75 (patch)
tree1b645adb7f8e5e89c6f07d2d7f756ed5c0d49d75 /CMakeLists.txt
parente751cde8954a09ea32f67a8bf7974b4dc1395f2e (diff)
downloadfirewall3-533f8345ab185d0c6f93565e68056edb093e3c75.tar.gz
build: disable the format-truncation warning error to fix gcc 7 build errors
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e2a88e7..3799bc7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,7 @@
cmake_minimum_required(VERSION 2.6)
PROJECT(firewall3 C)
-ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -Wmissing-declarations)
+ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -Wmissing-declarations -Wno-error=format-truncation)
SET(iptc_libs ip4tc)