summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Danzberger <daniel@dd-wrt.com>2021-08-02 11:57:09 +0200
committerDaniel Golle <daniel@makrotopia.org>2021-08-03 21:38:39 +0100
commit9e26563f1e5a75ada494ca5cb5382a9de00e480c (patch)
treed3cee3a0ea09093d323ba6ce75df23bcd9cd16e2
parent141ac851aee06512934ba6fbd90af78066593844 (diff)
downloadfstools-9e26563f1e5a75ada494ca5cb5382a9de00e480c.tar.gz
libblkid-tiny: install header file to include dir
Hence libblkid-tiny is a shared lib, it makes sense to install it's header to the system incldue/ dir for other applications to use it. Signed-off-by: Daniel Danzberger <daniel@dd-wrt.com>
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 422f27d..9a87979 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,6 +38,7 @@ ADD_LIBRARY(blkid-tiny SHARED
libblkid-tiny/f2fs.c
)
INSTALL(TARGETS blkid-tiny LIBRARY DESTINATION lib)
+INSTALL(FILES libblkid-tiny/libblkid-tiny.h DESTINATION include)
ADD_LIBRARY(ubi-utils STATIC
libubi/libubi.c