summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-04-03 18:38:18 +0100
committerJohn Crispin <blogic@openwrt.org>2014-04-03 23:03:46 +0100
commit8603b6f2e7782437f3af16778b231ec9c1045f09 (patch)
tree909dae619547c6595d7c1a0a16451079d4c46249 /CMakeLists.txt
parentdbd3dc58391b750d9ad8403e89f79457bd49dc90 (diff)
downloadfstools-8603b6f2e7782437f3af16778b231ec9c1045f09.tar.gz
move files around
Signed-off-by: John Crispin <blogic@openwrt.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 8 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5266785..b81d66c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,15 +6,14 @@ ADD_DEFINITIONS(-Os -ggdb -Wall -Werror --std=gnu99 -Wmissing-declarations)
SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
ADD_EXECUTABLE(fs-state fs-state.c
- backend/base.c
- backend/snapshot.c
- backend/extroot.c
- backend/jffs2.c
- driver/volume.c
- driver/mtd.c
- lib/mount.c
- lib/find.c)
-
+ libfstools/mount_root.c
+ libfstools/snapshot.c
+ libfstools/extroot.c
+ libfstools/jffs2.c
+ libfstools/volume.c
+ libfstools/mtd.c
+ libfstools/mount.c
+ libfstools/find.c)
TARGET_LINK_LIBRARIES(fs-state ubox)
INSTALL(TARGETS fs-state RUNTIME DESTINATION sbin)