summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-07-31 20:36:27 +0200
committerJo-Philipp Wich <jo@mein.io>2018-07-31 20:36:35 +0200
commit65b8333f5b66f8812c1ed21a4d5b28a576e6ba63 (patch)
treeecff83b45cfdfda50519cc23da717aa5cdb37c3c /Makefile
parent3c30b171707858256306db36627649ddfd03bc43 (diff)
downloadiwinfo-65b8333f5b66f8812c1ed21a4d5b28a576e6ba63.tar.gz
Revert "build: compile with -ffunction-sections, -fdata-sections and LTO"
This reverts commit a51413988caaff7001f47c8a62bff11a72ca48bc. It causes assertion failures in ld and requires changes to linked libraries, so drop this for now. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index d4f0f00..715c03e 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
IWINFO_BACKENDS = $(BACKENDS)
-IWINFO_CFLAGS = $(CFLAGS) -std=gnu99 -fstrict-aliasing -ffunction-sections -fdata-sections -flto -Iinclude
-IWINFO_LDFLAGS = -Wl,-gc-sections -flto -luci -lubox -lubus
+IWINFO_CFLAGS = $(CFLAGS) -std=gnu99 -fstrict-aliasing -Iinclude
+IWINFO_LDFLAGS = -luci -lubox -lubus
IWINFO_LIB = libiwinfo.so
IWINFO_LIB_LDFLAGS = $(LDFLAGS) -shared