summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorrofl0r <retnyg@gmx.net>2014-07-10 17:54:32 +0200
committerrofl0r <retnyg@gmx.net>2014-07-10 17:54:32 +0200
commit5d60207c8b41080aeeddc03e9b95f250bbf3e439 (patch)
tree57ccef4bc4e74ba5592a84533f3b4a952fb6cfbd /Makefile
downloadlibnl-tiny-5d60207c8b41080aeeddc03e9b95f250bbf3e439.tar.gz
import libnl-tiny rev 49d9e43e from openwrt
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..37ac26f
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,52 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libnl-tiny
+PKG_VERSION:=0.1
+PKG_RELEASE:=3
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libnl-tiny
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=netlink socket library
+endef
+
+define Package/libnl-tiny/description
+ This package contains a stripped down version of libnl
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ all
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig $(1)/usr/include/libnl-tiny
+ $(CP) $(PKG_BUILD_DIR)/include/* $(1)/usr/include/libnl-tiny
+ $(CP) $(PKG_BUILD_DIR)/libnl-tiny.so $(1)/usr/lib/
+ $(CP) ./files/libnl-tiny.pc $(1)/usr/lib/pkgconfig
+endef
+
+define Package/libnl-tiny/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/libnl-tiny.so $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libnl-tiny))