summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorrofl0r <retnyg@gmx.net>2015-11-22 12:43:55 +0000
committerrofl0r <retnyg@gmx.net>2015-11-22 12:43:55 +0000
commitedf21ef7aa9423b95aa49e2018eacfbcf1f3eac9 (patch)
tree0fe2b6cee6123466a45d27933c8614d3ccc506c8 /Makefile
parent91420e5fbbe932f93d55f0581bf43256a3dae8dc (diff)
downloadlibnl-tiny-edf21ef7aa9423b95aa49e2018eacfbcf1f3eac9.tar.gz
Makefile: make AR and RANLIB customizable
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 9359585..0e1a11b 100644
--- a/Makefile
+++ b/Makefile
@@ -3,6 +3,8 @@ libdir=$(prefix)/lib
includedir=$(prefix)/include
CC=gcc
+AR=ar
+RANLIB=ranlib
WFLAGS=-Wall
CFLAGS?=-O2
INCLUDES=-Iinclude
@@ -40,8 +42,8 @@ $(SHAREDLIB): $(OBJS)
$(STATICLIB): $(OBJS)
rm -f $@
- ar rc $@ $^
- ranlib $@
+ $(AR) rc $@ $^
+ $(RANLIB) $@
$(PCFILE): $(PCFILE).in
sed s,@prefix@,$(prefix),g $< > $@