summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-10-19 21:15:26 +0200
committerFelix Fietkau <nbd@openwrt.org>2011-10-19 21:15:26 +0200
commit1ba3b8a006b57646d55522bb9efa77769361ff39 (patch)
tree6452056f863fd70d69fbd7f0c29cb347fe6822d5 /CMakeLists.txt
parent937a95ad71e00e99bd21add761e2f810b7fb4026 (diff)
downloadnetifd-1ba3b8a006b57646d55522bb9efa77769361ff39.tar.gz
add -Wmissing-declarations to cflags
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a57123e..adb2c07 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,7 @@
cmake_minimum_required(VERSION 2.6)
PROJECT(netifd C)
-ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99)
+ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -Wmissing-declarations)
SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")