summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-10-02 18:38:58 +0200
committerFelix Fietkau <nbd@openwrt.org>2011-10-02 18:38:58 +0200
commit216f718323126aa5b89b820363c20f49488cbba1 (patch)
treebb1aaf719873bd0cb5847ef69760376d495331f5 /CMakeLists.txt
parent1c669b1e235dd6662a6165fe8bc6ae069da22de4 (diff)
downloadnetifd-216f718323126aa5b89b820363c20f49488cbba1.tar.gz
only override the uci conf dir in dummy mode
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index de0c74b..8fb8ae1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,7 @@ IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux")
SET(SOURCES ${SOURCES} system-linux.c)
SET(LIBS ${LIBS} nl)
ELSE()
+ ADD_DEFINITIONS(-DDUMMY_MODE=1)
SET(SOURCES ${SOURCES} system-dummy.c)
ENDIF()