summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-09-09 21:30:59 +0200
committerFelix Fietkau <nbd@openwrt.org>2011-09-09 21:30:59 +0200
commit23cfcee20f43d824d61fadef48af84a83d5b8816 (patch)
treefd84ddf5456fc300daa5c1993d87ae23249db9ac /CMakeLists.txt
parentcfc905f003aefe4735f8645c561f789ffd0b1f30 (diff)
downloadnetifd-23cfcee20f43d824d61fadef48af84a83d5b8816.tar.gz
add work in progress code for enumerating shell protocol handlers
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 13 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c06733e..43ced00 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,9 +5,20 @@ ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3)
SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
+IF(APPLE)
+ INCLUDE_DIRECTORIES(/opt/local/include)
+ LINK_DIRECTORIES(/opt/local/lib)
+ENDIF()
+
IF(DEBUG)
ADD_DEFINITIONS(-DDEBUG -O0)
ENDIF()
-ADD_EXECUTABLE(netifd main.c utils.c interface.c interface-ip.c proto.c proto-static.c config.c device.c bridge.c vlan.c ubus.c system-dummy.c)
-TARGET_LINK_LIBRARIES(netifd ubox ubus uci)
+
+ADD_EXECUTABLE(netifd
+ main.c utils.c interface.c interface-ip.c
+ proto.c proto-static.c proto-shell.c
+ config.c device.c bridge.c vlan.c ubus.c
+ system-dummy.c)
+
+TARGET_LINK_LIBRARIES(netifd ubox ubus uci json)