summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-09-11 22:38:33 +0200
committerFelix Fietkau <nbd@openwrt.org>2011-09-11 22:38:33 +0200
commit25cb39d2bcf72442c7d793a71b5a3950f701e302 (patch)
treecc67c934c54fb3ea8014dc464e3c01d92f682917 /CMakeLists.txt
parentb7ab9ef01354a2d1c36d7089be366d1684b5ca35 (diff)
downloadnetifd-25cb39d2bcf72442c7d793a71b5a3950f701e302.tar.gz
only use -g3 with -DDEBUG
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b264b1e..6da39df 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,7 @@
cmake_minimum_required(VERSION 2.6)
PROJECT(netifd C)
-ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3)
+ADD_DEFINITIONS(-Os -Wall -Werror)
SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
@@ -11,7 +11,7 @@ IF(APPLE)
ENDIF()
IF(DEBUG)
- ADD_DEFINITIONS(-DDEBUG -O0)
+ ADD_DEFINITIONS(-DDEBUG -O0 --std=gnu99 -g3)
ENDIF()