summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGioacchino Mazzurco <gio@eigenlab.org>2014-06-10 19:29:13 +0200
committerFelix Fietkau <nbd@openwrt.org>2014-06-11 12:22:23 +0200
commit59217785704fca27d2c7a19e279d27c384a452cd (patch)
tree5de87f928553d8b56c1681151026c4b14f0f17c4 /CMakeLists.txt
parentf8981d9933683e1a8314fa86ac610f8e9a22661c (diff)
downloadnetifd-59217785704fca27d2c7a19e279d27c384a452cd.tar.gz
Add vlan 802.1q/802.1ad support as netifd devices
At moment netifd supports just 802.1q vlan, you can configure them using a concise but "hacky" syntax using an interface config section, with this patch netifd acquire the capability of configuring 802.1ad and 802.1q vlan using config device sections, so you can define a vlan device plus interface with something like this: config device 'test' option type '8021ad' option name 'test' option ifname 'eth0' option vid '1000' config interface 'testif' option ifname 'test' option proto 'none' option auto '1' old syntax for 802.1q keeps working so no retrocompatibility problems, to keep retrocompatibility means also that user must not use name/ifname like eth0.2 for devices declared with the new style because this would trigger the "old style" when interface config section is parsed Signed-off-by: Gioacchino Mazzurco <gmazzurco89@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 65da3cf..e648b03 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,7 +15,7 @@ SET(SOURCES
interface.c interface-ip.c interface-event.c
iprule.c proto.c proto-static.c proto-shell.c
config.c device.c bridge.c vlan.c alias.c
- macvlan.c ubus.c wireless.c)
+ macvlan.c ubus.c vlandev.c wireless.c)
find_library(json NAMES json-c json)