summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2017-02-10 06:30:17 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-11 21:48:38 +0100
commit6397f5edb977b5963aa8eec1deaa709355bbbc7d (patch)
treee8e8bf3c162794e574e458b06a3b9d6d8c2c0afb /CMakeLists.txt
parent6228d0f21b2dcf20d7b2223c43f8b90b9b51bc4d (diff)
downloadnetifd-6397f5edb977b5963aa8eec1deaa709355bbbc7d.tar.gz
device: add veth support
The veth config code mostly handles the primary interface of a veth pair, the secondary interface is not explicitly referenced and will be found as an unrelated interface after the pair has been created. This doesn't only allow us to keep the veth code simple (and similar to existing device handlers), but will also avoid complicating handling unnecessarily in case the secondary interface is moved into another network namespace. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1f35d26..d54b6fa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,7 @@ SET(SOURCES
main.c utils.c system.c tunnel.c handler.c
interface.c interface-ip.c interface-event.c
iprule.c proto.c proto-static.c proto-shell.c
- config.c device.c bridge.c vlan.c alias.c
+ config.c device.c bridge.c veth.c vlan.c alias.c
macvlan.c ubus.c vlandev.c wireless.c)