summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-05-04 15:49:53 +0200
committerFelix Fietkau <nbd@nbd.name>2017-05-04 15:49:58 +0200
commit6b9c2673173f9636647e021a84d560c0863b1b99 (patch)
treefda3b3328430413fe0c206ff5a3f1fb110edebcb /CMakeLists.txt
parent11cb9cfbb088740ee7ee5e6c6b661958c0f962cb (diff)
downloadnetifd-6b9c2673173f9636647e021a84d560c0863b1b99.tar.gz
build: suppress format truncation warnings to avoid errors with gcc7
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d54b6fa..ecdb946 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,7 @@
cmake_minimum_required(VERSION 2.6)
PROJECT(netifd C)
-ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -Wmissing-declarations)
+ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -Wmissing-declarations -Wno-format-truncation)
SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")