summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2018-07-05 03:13:03 +0200
committerAlexander Couzens <lynxis@fe80.eu>2018-07-11 22:12:15 +0200
commit908a9f4f1027fdc813dc3a0c0f6231194bc5be3f (patch)
tree0fc6e7371b760e7d6b50770128151652ac4686fa /CMakeLists.txt
parentb06b01178e4908dfd380b95a922f407ed8274fed (diff)
downloadnetifd-908a9f4f1027fdc813dc3a0c0f6231194bc5be3f.tar.gz
CMakeLists.txt: add -Wimplicit-fallthrough to the compiler flags
Signed-off-by: Alexander Couzens <lynxis@fe80.eu> Acked-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 696412b..50f62bd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,7 @@
cmake_minimum_required(VERSION 2.6)
PROJECT(netifd C)
-ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -Wmissing-declarations -Wno-unknown-warning-option -Wno-format-truncation)
+ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -Wmissing-declarations -Wno-unknown-warning-option -Wno-format-truncation -Wimplicit-fallthrough)
SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")