summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-10-12 16:16:58 +0200
committerFelix Fietkau <nbd@openwrt.org>2011-10-12 16:16:58 +0200
commitaaa6302c203cf4fecf121f485f0cb0cf9bf067be (patch)
tree687b63160e30b90a7e06f3ee85ec725d4bc13dcb /CMakeLists.txt
parentc8fb7658d2317a81b41d5729ed17152d567f4619 (diff)
downloadnetifd-aaa6302c203cf4fecf121f485f0cb0cf9bf067be.tar.gz
move --std=gnu99 to the main cflags
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d20b490..a57123e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,7 @@
cmake_minimum_required(VERSION 2.6)
PROJECT(netifd C)
-ADD_DEFINITIONS(-Os -Wall -Werror)
+ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99)
SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
@@ -32,7 +32,7 @@ ELSE()
ENDIF()
IF(DEBUG)
- ADD_DEFINITIONS(-DDEBUG --std=gnu99 -g3)
+ ADD_DEFINITIONS(-DDEBUG -g3)
ENDIF()