summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2076fc9..f7e9a04 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,7 +23,8 @@ SET(LIBS
ubox ubus uci ${json} blobmsg_json)
IF (NOT DEFINED LIBNL_LIBS)
- SET(LIBNL_LIBS -lnl)
+ FIND_LIBRARY(libnl NAMES libnl-3 libnl nl-3 nl)
+ SET(LIBNL_LIBS ${libnl})
ENDIF()
IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux" AND NOT DUMMY_MODE)