summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 461c07c..a6e228a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,9 +19,13 @@ SET(SOURCES
SET(LIBS
ubox ubus uci json blobmsg_json)
+IF (NOT DEFINED LIBNL_LIBS)
+ SET(LIBNL_LIBS -lnl)
+ENDIF()
+
IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux" AND NOT DUMMY_MODE)
SET(SOURCES ${SOURCES} system-linux.c)
- SET(LIBS ${LIBS} nl)
+ SET(LIBS ${LIBS} ${LIBNL_LIBS})
ELSE()
ADD_DEFINITIONS(-DDUMMY_MODE=1)
SET(SOURCES ${SOURCES} system-dummy.c)