summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2023-05-09 21:39:58 +0200
committerPaul Spooren <mail@aparcar.org>2023-05-10 00:07:15 +0200
commit695a22ab157577a4143f7a76bcbdaa59305905e3 (patch)
tree8be620145aa994dea3726a03a2aaaa228af2c504
parente500494771537b9f42f78e4d907bed18b6383606 (diff)
downloadopenwrt-22.03.tar.gz
build: generate index.jsonopenwrt-22.03
The index.json file lies next to Packages index files and contains a json dict with the package architecture and a dict of package names and versions. This can be used for downstream project to know what packages in which versions are available. Signed-off-by: Paul Spooren <mail@aparcar.org> (cherry picked from commit 218ce40cd738f3373438aab82467807a8707fb9c)
-rw-r--r--package/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index 209be34674..4b8df7f484 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -92,6 +92,10 @@ $(curdir)/index: FORCE
$(call ERROR_MESSAGE,WARNING: Applying padding in $$d/Packages to workaround usign SHA-512 bug!); \
{ echo ""; echo ""; } >> Packages;; \
esac; \
+ echo -n '{"architecture": "$(ARCH_PACKAGES)", "packages":{' > index.json; \
+ sed -n -e 's/^Package: \(.*\)$$/"\1":/p' -e 's/^Version: \(.*\)$$/"\1",/p' Packages | tr '\n' ' ' >> index.json; \
+ echo '}}' >> index.json; \
+ sed -i 's/, }}/}}/' index.json; \
gzip -9nc Packages > Packages.gz; \
); done
ifdef CONFIG_SIGNED_PACKAGES