summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2023-05-13 18:55:44 -0400
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-15 16:14:44 +0200
commit02884158771b0ec945c7cdfaf83d13841324d666 (patch)
treef38a8198c6cef14595f38796876470cb2ab41a56
parentd3c3b79c1e46c49cfa5de9df6a740d5fcda46471 (diff)
downloadopenwrt-02884158771b0ec945c7cdfaf83d13841324d666.tar.gz
gettext-full: add missing link to libunistring
Running autoreconf or autogen.sh is causing the gettext-runtime subdirectory to have a configure script that looks for and attempts to link to an external libunistring. However, the macros and symbols for supporting that configuration are not present in this subdirectory yet. This results in some host machines to not build the included libunistring objects for libgrt, but at the same time, also not input the proper flag to the linker for linking to an external library when it is found or even when explicitly setting configuration to use a prefix for libunistring, resulting in the common linking failure "undefined reference". Some similar (and old...) upstream commits do the same thing, but only for gettext-tools and libgettextpo. Ref: ae943bcc1 ("Link with libunistring, if it exists.") # gettext.git Ref: 61e21a72f ("Avoid link error in programs that use libgettextpo.") # gettext.git Signed-off-by: Michael Pratt <mcpratt@pm.me>
-rw-r--r--package/libs/gettext-full/patches/200-libunistring-missing-link.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/libs/gettext-full/patches/200-libunistring-missing-link.patch b/package/libs/gettext-full/patches/200-libunistring-missing-link.patch
new file mode 100644
index 0000000000..2e1dbf84e8
--- /dev/null
+++ b/package/libs/gettext-full/patches/200-libunistring-missing-link.patch
@@ -0,0 +1,21 @@
+--- a/autogen.sh
++++ b/autogen.sh
+@@ -78,6 +78,7 @@ if ! $skip_gnulib; then
+ getopt-gnu
+ gettext-h
+ havelib
++ libunistring-optional
+ memmove
+ noreturn
+ progname
+--- a/gettext-runtime/src/Makefile.am
++++ b/gettext-runtime/src/Makefile.am
+@@ -40,7 +40,7 @@ envsubst_SOURCES = envsubst.c
+
+ # Link dependencies.
+ # Need @LTLIBICONV@ because striconv.c uses iconv().
+-LDADD = ../gnulib-lib/libgrt.a @LTLIBINTL@ @LTLIBICONV@ $(WOE32_LDADD)
++LDADD = ../gnulib-lib/libgrt.a $(LTLIBUNISTRING) @LTLIBINTL@ @LTLIBICONV@ $(WOE32_LDADD)
+
+ # Specify installation directory, for --enable-relocatable.
+ gettext_CFLAGS = -DINSTALLDIR=\"$(bindir)\"