summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2023-05-17 20:42:56 +0200
committerDavid Bauer <mail@david-bauer.net>2023-05-18 01:44:31 +0200
commit13dff42e37e259d2b36cb141bda205f3824017d0 (patch)
treec97dcaaf89e70f1210086b251113c8f92838170f
parentf7665a0f1a2da63e2046119c0c3de578f16651ce (diff)
downloadopenwrt-13dff42e37e259d2b36cb141bda205f3824017d0.tar.gz
mt76: add MT7981 firmware packages
Package the firmware required for MT7981 to bring up the radio. Signed-off-by: David Bauer <mail@david-bauer.net>
-rw-r--r--package/kernel/mt76/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/mt76/Makefile b/package/kernel/mt76/Makefile
index 1a7c2ec8c7..04db7fe32c 100644
--- a/package/kernel/mt76/Makefile
+++ b/package/kernel/mt76/Makefile
@@ -245,6 +245,12 @@ define KernelPackage/mt7916-firmware
TITLE:=MediaTek MT7916 firmware
endef
+define KernelPackage/mt7981-firmware
+ $(KernelPackage/mt76-default)
+ DEPENDS:=@TARGET_mediatek_filogic
+ TITLE:=MediaTek MT7981 firmware
+endef
+
define KernelPackage/mt7986-firmware
$(KernelPackage/mt76-default)
DEPENDS:=@TARGET_mediatek_filogic
@@ -497,6 +503,15 @@ define KernelPackage/mt7916-firmware/install
$(1)/lib/firmware/mediatek
endef
+define KernelPackage/mt7981-firmware/install
+ $(INSTALL_DIR) $(1)/lib/firmware/mediatek
+ cp \
+ $(PKG_BUILD_DIR)/firmware/mt7981_wa.bin \
+ $(PKG_BUILD_DIR)/firmware/mt7981_wm.bin \
+ $(PKG_BUILD_DIR)/firmware/mt7981_rom_patch.bin \
+ $(1)/lib/firmware/mediatek
+endef
+
define KernelPackage/mt7986-firmware/install
$(INSTALL_DIR) $(1)/lib/firmware/mediatek
cp \
@@ -548,6 +563,7 @@ $(eval $(call KernelPackage,mt7663s))
$(eval $(call KernelPackage,mt7915-firmware))
$(eval $(call KernelPackage,mt7915e))
$(eval $(call KernelPackage,mt7916-firmware))
+$(eval $(call KernelPackage,mt7981-firmware))
$(eval $(call KernelPackage,mt7986-firmware))
$(eval $(call KernelPackage,mt7921-firmware))
$(eval $(call KernelPackage,mt7921-common))