summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2023-05-08 12:47:29 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-15 20:39:21 +0200
commit6ff12094cd4789ba992b07eed2237a7ad958eb98 (patch)
treefcefa09d9ef51fd47b9fa0c7302b3dfc390bc782
parentfff878c5bcda6dea337c97a95721bf8cf73e4560 (diff)
downloadopenwrt-6ff12094cd4789ba992b07eed2237a7ad958eb98.tar.gz
libselinux: fix compilation with musl 1.2.4
musl 1.2.4 deprecated legacy "LFS64" ("large file support") interfaces so just having _GNU_SOURCE defined is not enough anymore. _LARGEFILE64_SOURCE has to be defined in the source, or CFLAGS can be used to pass -D_LARGEFILE64_SOURCE to allow to keep using LFS64 definitions. Signed-off-by: Robert Marko <robimarko@gmail.com>
-rw-r--r--package/libs/libselinux/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/libs/libselinux/Makefile b/package/libs/libselinux/Makefile
index 7246d85566..a794270450 100644
--- a/package/libs/libselinux/Makefile
+++ b/package/libs/libselinux/Makefile
@@ -115,6 +115,7 @@ HOST_MAKE_FLAGS += \
ifeq ($(CONFIG_USE_MUSL),y)
MAKE_FLAGS += FTS_LDLIBS=-lfts
+TARGET_CFLAGS += -D_LARGEFILE64_SOURCE
endif
MAKE_FLAGS += \