summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2022-10-04 00:30:21 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2022-10-05 17:49:19 +0200
commit7df959449cabee021aa42cab3a7172e0972a79a7 (patch)
treedba282838bd2447a1e688e0e4f4113f907b8cd09
parent3bd04767badd215bf4d005f0b997b2cee5b2d8c3 (diff)
downloadopenwrt-7df959449cabee021aa42cab3a7172e0972a79a7.tar.gz
rules.mk: move DOWNLOAD_CHECK_CERTIFICATE to include/download.mk
Move DOWNLOAD_CHECK_CERTIFICATE to include/download.mk as it's a better place than exporting it in the global rules.mk makefile. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
-rw-r--r--include/download.mk3
-rw-r--r--rules.mk3
2 files changed, 3 insertions, 3 deletions
diff --git a/include/download.mk b/include/download.mk
index 76bd374cf7..9ff71540f7 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -18,6 +18,9 @@ endif
DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
+# Export options for download.pl
+export DOWNLOAD_CHECK_CERTIFICATE:=$(CONFIG_DOWNLOAD_CHECK_CERTIFICATE)
+
define dl_method_git
$(if $(filter https://github.com/% git://github.com/%,$(1)),github_archive,git)
endef
diff --git a/rules.mk b/rules.mk
index 2072658e78..2de43d490d 100644
--- a/rules.mk
+++ b/rules.mk
@@ -257,9 +257,6 @@ ESED:=$(STAGING_DIR_HOST)/bin/sed -E -i -e
MKHASH:=$(STAGING_DIR_HOST)/bin/mkhash
# MKHASH is used in /scripts, so we export it here.
export MKHASH
-# DOWNLOAD_CHECK_CERTIFICATE is used in /scripts, so we export it here.
-DOWNLOAD_CHECK_CERTIFICATE:=$(CONFIG_DOWNLOAD_CHECK_CERTIFICATE)
-export DOWNLOAD_CHECK_CERTIFICATE
CP:=cp -fpR
LN:=ln -sf
XARGS:=xargs -r