summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-05-16 19:03:29 +0800
committerPetr Štetiar <ynezz@true.cz>2023-05-16 16:32:59 +0200
commit8f455f7c5e0c1fe7c8c2297a2fa4b2a6c7d6c91e (patch)
tree38edb190db4688c2e223c1d836a089e6a0d97b45
parent95577e7bd108b5c70e5c757ce5b73545e068b8d6 (diff)
downloadopenwrt-8f455f7c5e0c1fe7c8c2297a2fa4b2a6c7d6c91e.tar.gz
f2fs-tools: fix compilation with musl 1.2.4
musl 1.2.4 deprecated legacy "LFS64" ("large file support") interfaces and autotools failed to check the lseek64 function. Force enable ac_cv_func_lseek64 to workaround it. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
-rw-r--r--package/utils/f2fs-tools/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/utils/f2fs-tools/Makefile b/package/utils/f2fs-tools/Makefile
index 99d402af6c..c4e3720dd8 100644
--- a/package/utils/f2fs-tools/Makefile
+++ b/package/utils/f2fs-tools/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=f2fs-tools
PKG_VERSION:=1.15.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git/snapshot/
@@ -111,6 +111,10 @@ endif
CONFIGURE_VARS += \
ac_cv_file__git=no
+ifneq ($(CONFIG_USE_MUSL),)
+ CONFIGURE_VARS += ac_cv_func_lseek64=yes
+endif
+
define Package/libf2fs/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) \