summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgi Valkov <gvalkov@gmail.com>2023-05-13 02:22:12 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2023-05-13 14:09:53 +0200
commit9145c4fbcb655b2f56c76012da85cb203fdbc72b (patch)
tree80fce9b5bc65651cf6d6d8cfc9e074641a68c274
parent4e5aac472935ce3ba3abc9bd72b880951843092b (diff)
downloadopenwrt-9145c4fbcb655b2f56c76012da85cb203fdbc72b.tar.gz
fortify-headers: fix build error when _REDIR_TIME64 is not defined
some targets do not define the _REDIR_TIME64 macro resulting in a build error regression since ddfe5678a448ac8875e94f2fb4ddca67416fa14a fix by checking if the macro is defined [1] https://github.com/openwrt/openwrt/issues/12587 Fixes: #12587 Fixes: ddfe5678a448 ("fortify-headers: fix inconsistent time_t version of ppoll") Signed-off-by: Georgi Valkov <gvalkov@gmail.com>
-rw-r--r--toolchain/fortify-headers/Makefile2
-rw-r--r--toolchain/fortify-headers/patches/001-__ppoll_time64.patch2
2 files changed, 2 insertions, 2 deletions
diff --git a/toolchain/fortify-headers/Makefile b/toolchain/fortify-headers/Makefile
index 1950eb1fdc..3362fb427a 100644
--- a/toolchain/fortify-headers/Makefile
+++ b/toolchain/fortify-headers/Makefile
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/target.mk
PKG_NAME:=fortify-headers
PKG_VERSION:=1.1
-PKG_RELEASE=2
+PKG_RELEASE=3
PKG_SOURCE_URL:=https://dl.2f30.org/releases
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/toolchain/fortify-headers/patches/001-__ppoll_time64.patch b/toolchain/fortify-headers/patches/001-__ppoll_time64.patch
index 9c6fea3e66..05f8c71714 100644
--- a/toolchain/fortify-headers/patches/001-__ppoll_time64.patch
+++ b/toolchain/fortify-headers/patches/001-__ppoll_time64.patch
@@ -5,7 +5,7 @@
}
-#ifdef _GNU_SOURCE
-+#if defined(_GNU_SOURCE) && !_REDIR_TIME64
++#if defined(_GNU_SOURCE) && !(defined(_REDIR_TIME64) && _REDIR_TIME64)
#undef ppoll
_FORTIFY_FN(ppoll) int ppoll(struct pollfd *__f, nfds_t __n, const struct timespec *__s,
const sigset_t *__m)