summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2023-05-15 21:56:27 +0200
committerDaniel Golle <daniel@makrotopia.org>2023-05-15 22:03:46 +0200
commitd26ecbcf95e2c2ecf5380fdee733c6b46276e265 (patch)
tree3c84e79700fd5e6a812dd695da872021abe61c05
parentd53fe5d9ce62c0fe9f5bc5c35cab15327a105fbd (diff)
downloadopenwrt-d26ecbcf95e2c2ecf5380fdee733c6b46276e265.tar.gz
linux-firmware: move firmware file for mt7601u
The firmware file for mt7601u (MediaTek MT7601U Wireless MACs) has been moved to the mediatek/ folder by commit 8451c2b1 mt76xx: Move the old Mediatek WiFi firmware to mediatek Address this by updating the location of the firmware file in our linux-firmware Makefile generating the mt7601u-firmware package. All other MediaTek Wi-Fi firmware files are supplied by OpenWrt's own repository rather than being taken from linux-firmware. Fixes: d53fe5d9ce ("linux-firmware: update to 20230515") Signed-off-by: Daniel Golle <daniel@makrotopia.org>
-rw-r--r--package/firmware/linux-firmware/mediatek.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/firmware/linux-firmware/mediatek.mk b/package/firmware/linux-firmware/mediatek.mk
index 77167aa8fe..a0eccb8f4d 100644
--- a/package/firmware/linux-firmware/mediatek.mk
+++ b/package/firmware/linux-firmware/mediatek.mk
@@ -1,9 +1,9 @@
Package/mt7601u-firmware = $(call Package/firmware-default,MediaTek MT7601U firmware)
define Package/mt7601u-firmware/install
- $(INSTALL_DIR) $(1)/lib/firmware
+ $(INSTALL_DIR) $(1)/lib/firmware/mediatek
$(INSTALL_DATA) \
- $(PKG_BUILD_DIR)/mt7601u.bin \
- $(1)/lib/firmware
+ $(PKG_BUILD_DIR)/mediatek/mt7601u.bin \
+ $(1)/lib/firmware/mediatek
endef
$(eval $(call BuildPackage,mt7601u-firmware))