summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2023-05-04 21:40:15 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-12 13:02:43 +0200
commitd798617d4aded6b922764bd5fea8651e12206afe (patch)
tree2e1a786781a75ec00a9766c87b4ff70e082e0b1c
parent330ad3e98fc2f33c40dbf6dd3dd08527afbd9f1f (diff)
downloadopenwrt-d798617d4aded6b922764bd5fea8651e12206afe.tar.gz
treewide: remove all @{lt,gt,ge,le} appearances affecting 5.10 kernel
We only use 5.15 kernel. So remove all those unnecessary appearances. Signed-off-by: Nick Hainke <vincent@systemli.org>
-rw-r--r--package/kernel/linux/modules/block.mk6
-rw-r--r--package/kernel/linux/modules/crypto.mk7
-rw-r--r--package/kernel/linux/modules/fs.mk6
-rw-r--r--package/kernel/linux/modules/iio.mk2
-rw-r--r--package/kernel/linux/modules/input.mk8
-rw-r--r--package/kernel/linux/modules/netdevices.mk2
-rw-r--r--package/kernel/linux/modules/netfilter.mk1
-rw-r--r--package/kernel/linux/modules/spi.mk5
-rw-r--r--package/kernel/linux/modules/usb.mk5
-rw-r--r--package/kernel/linux/modules/video.mk2
-rw-r--r--package/kernel/linux/modules/virt.mk2
-rw-r--r--target/linux/bcm27xx/modules/video.mk1
12 files changed, 18 insertions, 29 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index f6c9df0698..bdf84e8ae2 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -521,13 +521,13 @@ define KernelPackage/scsi-core
TITLE:=SCSI device support
KCONFIG:= \
CONFIG_SCSI \
- CONFIG_SCSI_COMMON@ge5.15 \
+ CONFIG_SCSI_COMMON \
CONFIG_BLK_DEV_SD
FILES:= \
$(LINUX_DIR)/drivers/scsi/scsi_mod.ko \
- $(LINUX_DIR)/drivers/scsi/scsi_common.ko@ge5.15 \
+ $(LINUX_DIR)/drivers/scsi/scsi_common.ko \
$(LINUX_DIR)/drivers/scsi/sd_mod.ko
- AUTOLOAD:=$(call AutoLoad,40,scsi_mod scsi_common@ge5.15 sd_mod,1)
+ AUTOLOAD:=$(call AutoLoad,40,scsi_mod scsi_common sd_mod,1)
endef
$(eval $(call KernelPackage,scsi-core))
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 98bcb9e874..446801ae23 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -704,7 +704,6 @@ define KernelPackage/crypto-misc
CONFIG_CRYPTO_KHAZAD \
CONFIG_CRYPTO_SERPENT \
CONFIG_CRYPTO_TEA \
- CONFIG_CRYPTO_TGR192@lt5.12 \
CONFIG_CRYPTO_TWOFISH \
CONFIG_CRYPTO_TWOFISH_COMMON \
CONFIG_CRYPTO_TWOFISH_586 \
@@ -717,7 +716,6 @@ define KernelPackage/crypto-misc
$(LINUX_DIR)/crypto/cast6_generic.ko \
$(LINUX_DIR)/crypto/khazad.ko \
$(LINUX_DIR)/crypto/tea.ko \
- $(LINUX_DIR)/crypto/tgr192.ko@lt5.12 \
$(LINUX_DIR)/crypto/twofish_common.ko \
$(LINUX_DIR)/crypto/wp512.ko \
$(LINUX_DIR)/crypto/twofish_generic.ko \
@@ -725,7 +723,7 @@ define KernelPackage/crypto-misc
$(LINUX_DIR)/crypto/blowfish_generic.ko \
$(LINUX_DIR)/crypto/serpent_generic.ko
AUTOLOAD:=$(call AutoLoad,10,anubis camellia_generic cast_common \
- cast5_generic cast6_generic khazad tea tgr192@lt5.12 twofish_common \
+ cast5_generic cast6_generic khazad tea twofish_common \
wp512 blowfish_common serpent_generic)
ifndef CONFIG_TARGET_x86
AUTOLOAD+= $(call AutoLoad,10,twofish_generic blowfish_generic)
@@ -738,10 +736,9 @@ ifndef CONFIG_TARGET_x86_64
FILES+= \
$(LINUX_DIR)/arch/x86/crypto/twofish-i586.ko \
$(LINUX_DIR)/arch/x86/crypto/serpent-sse2-i586.ko \
- $(LINUX_DIR)/arch/x86/crypto/glue_helper.ko@lt5.12 \
$(LINUX_DIR)/crypto/cryptd.ko \
$(LINUX_DIR)/crypto/crypto_simd.ko
- AUTOLOAD+= $(call AutoLoad,10,cryptd glue_helper@lt5.12 \
+ AUTOLOAD+= $(call AutoLoad,10,cryptd \
serpent-sse2-i586 twofish-i586 blowfish_generic)
endef
endif
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 19fa9fcfc0..547cc79644 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -87,13 +87,13 @@ define KernelPackage/fs-cifs
SUBMENU:=$(FS_MENU)
TITLE:=CIFS support
KCONFIG:= \
- CONFIG_SMBFS_COMMON@ge5.15 \
+ CONFIG_SMBFS_COMMON \
CONFIG_CIFS \
CONFIG_CIFS_DFS_UPCALL=n \
CONFIG_CIFS_UPCALL=n
FILES:= \
- $(LINUX_DIR)/fs/smbfs_common/cifs_arc4.ko@ge5.15 \
- $(LINUX_DIR)/fs/smbfs_common/cifs_md4.ko@ge5.15 \
+ $(LINUX_DIR)/fs/smbfs_common/cifs_arc4.ko \
+ $(LINUX_DIR)/fs/smbfs_common/cifs_md4.ko \
$(LINUX_DIR)/fs/cifs/cifs.ko
AUTOLOAD:=$(call AutoLoad,30,cifs)
$(call AddDepends/nls)
diff --git a/package/kernel/linux/modules/iio.mk b/package/kernel/linux/modules/iio.mk
index c0e37f06c7..f901f87ddd 100644
--- a/package/kernel/linux/modules/iio.mk
+++ b/package/kernel/linux/modules/iio.mk
@@ -438,7 +438,7 @@ define KernelPackage/iio-sps30
CONFIG_SPS30_I2C
FILES:= \
$(LINUX_DIR)/drivers/iio/chemical/sps30.ko \
- $(LINUX_DIR)/drivers/iio/chemical/sps30_i2c.ko@ge5.14
+ $(LINUX_DIR)/drivers/iio/chemical/sps30_i2c.ko
AUTOLOAD:=$(call AutoProbe,sps30 sps30_i2c)
$(call AddDepends/iio)
endef
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 6270cdeb3b..6cc72207f3 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -179,10 +179,8 @@ define KernelPackage/input-touchscreen-ads7846
DEPENDS:=+kmod-hwmon-core +kmod-input-core +kmod-spi-bitbang
KCONFIG:= \
CONFIG_INPUT_TOUCHSCREEN=y \
- CONFIG_TOUCHSCREEN_PROPERTIES=y@lt5.13 \
CONFIG_TOUCHSCREEN_ADS7846
- FILES:=$(LINUX_DIR)/drivers/input/touchscreen/ads7846.ko \
- $(LINUX_DIR)/drivers/input/touchscreen/of_touchscreen.ko@lt5.13
+ FILES:=$(LINUX_DIR)/drivers/input/touchscreen/ads7846.ko
AUTOLOAD:=$(call AutoProbe,ads7846)
endef
@@ -199,10 +197,8 @@ define KernelPackage/input-touchscreen-edt-ft5x06
DEPENDS:=+kmod-i2c-core +kmod-input-core
KCONFIG:= \
CONFIG_INPUT_TOUCHSCREEN=y \
- CONFIG_TOUCHSCREEN_PROPERTIES=y@lt5.13 \
CONFIG_TOUCHSCREEN_EDT_FT5X06
- FILES:=$(LINUX_DIR)/drivers/input/touchscreen/edt-ft5x06.ko \
- $(LINUX_DIR)/drivers/input/touchscreen/of_touchscreen.ko@lt5.13
+ FILES:=$(LINUX_DIR)/drivers/input/touchscreen/edt-ft5x06.ko
AUTOLOAD:=$(call AutoProbe,edt-ft5x06)
endef
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 208518c3bf..ade6438b9c 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -1170,7 +1170,7 @@ define KernelPackage/of-mdio
KCONFIG:=CONFIG_OF_MDIO
FILES:= \
$(LINUX_DIR)/drivers/net/mdio/of_mdio.ko \
- $(LINUX_DIR)/drivers/net/mdio/fwnode_mdio.ko@ge5.15
+ $(LINUX_DIR)/drivers/net/mdio/fwnode_mdio.ko
AUTOLOAD:=$(call AutoLoad,41,of_mdio)
endef
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index 1772545f25..99a48a37d4 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -1141,7 +1141,6 @@ define KernelPackage/nft-bridge
FILES:=$(foreach mod,$(NFT_BRIDGE-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoProbe,$(notdir $(NFT_BRIDGE-m)))
KCONFIG:= \
- CONFIG_NF_LOG_BRIDGE=n@lt5.13 \
$(KCONFIG_NFT_BRIDGE)
endef
diff --git a/package/kernel/linux/modules/spi.mk b/package/kernel/linux/modules/spi.mk
index 5cdfc3b2b3..78a1c8a032 100644
--- a/package/kernel/linux/modules/spi.mk
+++ b/package/kernel/linux/modules/spi.mk
@@ -15,10 +15,9 @@ define KernelPackage/mmc-spi
CONFIG_SPI=y \
CONFIG_SPI_MASTER=y
FILES:=\
- $(if $(CONFIG_OF),$(LINUX_DIR)/drivers/mmc/host/of_mmc_spi.ko@lt5.13) \
- $(LINUX_DIR)/drivers/mmc/host/of_mmc_spi.ko@ge5.13 \
+ $(LINUX_DIR)/drivers/mmc/host/of_mmc_spi.ko \
$(LINUX_DIR)/drivers/mmc/host/mmc_spi.ko
- AUTOLOAD:=$(call AutoProbe,$(if $(CONFIG_OF),of_mmc_spi@lt5.13) of_mmc_spi@ge5.13 mmc_spi)
+ AUTOLOAD:=$(call AutoProbe,of_mmc_spi mmc_spi)
endef
define KernelPackage/mmc-spi/description
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 9c2e01357a..5747ad2166 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1823,9 +1823,8 @@ define KernelPackage/usb-xhci-mtk
KCONFIG:=CONFIG_USB_XHCI_MTK
HIDDEN:=1
FILES:= \
- $(LINUX_DIR)/drivers/usb/host/xhci-mtk.ko@lt5.13 \
- $(LINUX_DIR)/drivers/usb/host/xhci-mtk-hcd.ko@ge5.13
- AUTOLOAD:=$(call AutoLoad,54,xhci-mtk@lt5.13 xhci-mtk-hcd@gt5.13,1)
+ $(LINUX_DIR)/drivers/usb/host/xhci-mtk-hcd.ko
+ AUTOLOAD:=$(call AutoLoad,54,xhci-mtk-hcd,1)
$(call AddDepends/usb)
endef
diff --git a/package/kernel/linux/modules/video.mk b/package/kernel/linux/modules/video.mk
index 83f48ac849..a89ceef54b 100644
--- a/package/kernel/linux/modules/video.mk
+++ b/package/kernel/linux/modules/video.mk
@@ -376,7 +376,7 @@ define KernelPackage/drm-imx-ldb
CONFIG_DRM_PANEL_SITRONIX_ST7789V=n
FILES:=$(LINUX_DIR)/drivers/gpu/drm/imx/imx-ldb.ko \
$(LINUX_DIR)/drivers/gpu/drm/panel/panel-simple.ko \
- $(LINUX_DIR)/drivers/gpu/drm/drm_dp_aux_bus.ko@gt5.10
+ $(LINUX_DIR)/drivers/gpu/drm/drm_dp_aux_bus.ko
AUTOLOAD:=$(call AutoLoad,08,imx-ldb)
endef
diff --git a/package/kernel/linux/modules/virt.mk b/package/kernel/linux/modules/virt.mk
index 59a2d79563..85f47aacbf 100644
--- a/package/kernel/linux/modules/virt.mk
+++ b/package/kernel/linux/modules/virt.mk
@@ -104,7 +104,7 @@ define KernelPackage/vfio-pci
CONFIG_VFIO_PCI \
CONFIG_VFIO_PCI_IGD=y
FILES:= \
- $(LINUX_DIR)/drivers/vfio/pci/vfio-pci-core.ko@ge5.15 \
+ $(LINUX_DIR)/drivers/vfio/pci/vfio-pci-core.ko \
$(LINUX_DIR)/drivers/vfio/pci/vfio-pci.ko
AUTOLOAD:=$(call AutoProbe,vfio-pci)
endef
diff --git a/target/linux/bcm27xx/modules/video.mk b/target/linux/bcm27xx/modules/video.mk
index 7e80203cba..07e6594890 100644
--- a/target/linux/bcm27xx/modules/video.mk
+++ b/target/linux/bcm27xx/modules/video.mk
@@ -39,7 +39,6 @@ define KernelPackage/drm-vc4
FILES:= \
$(LINUX_DIR)/drivers/gpu/drm/vc4/vc4.ko \
$(LINUX_DIR)/drivers/gpu/drm/drm_kms_helper.ko \
- $(LINUX_DIR)/drivers/media/cec/cec.ko@lt5.10 \
$(LINUX_DIR)/drivers/media/cec/core/cec.ko
AUTOLOAD:=$(call AutoProbe,vc4)
endef