summaryrefslogtreecommitdiff
path: root/include/image.mk
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2022-11-22 00:37:39 +0000
committerDaniel Golle <daniel@makrotopia.org>2022-12-19 12:27:35 +0000
commit1bff0752bd5e7feb0f311224a09b3bf217a9aeb3 (patch)
tree2814f3624caca228376f7b2673de4eeb92a713da /include/image.mk
parent93ae4353cdf651ef0b5d8a4d40a6c29d8d3f655b (diff)
downloadopenwrt-1bff0752bd5e7feb0f311224a09b3bf217a9aeb3.tar.gz
image: fix device profile specific COMPILE targets
Commit a01d23e75 ("image: always rebuild kernel loaders") is a step in the right direction, but exposed some issues and regressions in the makefile. Some of the files made by device specific COMPILE targets start with an "append" command (i.e. >> instead of > redirection) and if the file already exists, the target file is the input to itself before the first recipe-specified input. Fixes: a01d23e75 ("image: always rebuild kernel loaders") Fixes: a7fb589e8 ("image: always rebuild kernel loaders") Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index e9dc53f82e..5d9d4acb41 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -520,6 +520,7 @@ define Device/Build/compile
$$(_COMPILE_TARGET): $(KDIR)/$(1)
$(eval $(call Device/Export,$(KDIR)/$(1)))
$(KDIR)/$(1): FORCE
+ rm -f $(KDIR)/$(1)
$$(call concat_cmd,$(COMPILE/$(1)))
endef