summaryrefslogtreecommitdiff
path: root/include/image.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-03-17 17:30:48 +0000
committerDaniel Golle <daniel@makrotopia.org>2021-03-17 17:45:34 +0000
commit6890f6fe13bb8dfc40dbca89703d4ab1116dd4bc (patch)
tree1f691e43baa12995f3307f3e04a00575ae99d628 /include/image.mk
parent4e6de4f0938de24f407b85b6328f5114103bd45a (diff)
downloadopenwrt-6890f6fe13bb8dfc40dbca89703d4ab1116dd4bc.tar.gz
include/image*: add support for device-tree overlays
Add new target feature 'dt-overlay' which makes DTC keep the symbol names in the generated dtb. Make sure additional DT overlay sources specified by the new device variable DEVICE_DTS_OVERLAY get compiled together with the main DTS (currently overlays got to be in the same folder). Let Build/fit pass the generated DT overlay blobs to mkits.sh. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/include/image.mk b/include/image.mk
index cae3e73438..29df0938bc 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -190,6 +190,7 @@ define Image/BuildDTB
-o $(2).tmp $(1)
$(LINUX_DIR)/scripts/dtc/dtc -O dtb \
-i$(dir $(1)) $(DTC_FLAGS) $(4) \
+ $(if $(CONFIG_HAS_DT_OVERLAY_SUPPORT),-@) \
-o $(2) $(2).tmp
$(RM) $(2).tmp
endef
@@ -393,6 +394,7 @@ define Device/Init
DEVICE_DTS :=
DEVICE_DTS_CONFIG :=
DEVICE_DTS_DIR :=
+ DEVICE_DTS_OVERLAY :=
DEVICE_FDT_NUM :=
SOC :=
@@ -416,8 +418,8 @@ DEFAULT_DEVICE_VARS := \
DEVICE_NAME KERNEL KERNEL_INITRAMFS KERNEL_INITRAMFS_IMAGE KERNEL_SIZE \
CMDLINE UBOOTENV_IN_UBI KERNEL_IN_UBI BLOCKSIZE PAGESIZE SUBPAGESIZE \
VID_HDR_OFFSET UBINIZE_OPTS UBINIZE_PARTS MKUBIFS_OPTS DEVICE_DTS \
- DEVICE_DTS_CONFIG DEVICE_DTS_DIR DEVICE_FDT_NUM SOC BOARD_NAME \
- UIMAGE_MAGIC UIMAGE_NAME \
+ DEVICE_DTS_CONFIG DEVICE_DTS_DIR DEVICE_DTS_OVERLAY DEVICE_FDT_NUM \
+ SOC BOARD_NAME UIMAGE_MAGIC UIMAGE_NAME \
SUPPORTED_DEVICES IMAGE_METADATA KERNEL_ENTRY KERNEL_LOADADDR \
UBOOT_PATH IMAGE_SIZE \
DEVICE_COMPAT_VERSION DEVICE_COMPAT_MESSAGE \
@@ -539,7 +541,7 @@ endef
endif
define Device/Build/kernel
- $$(eval $$(foreach dts,$$(DEVICE_DTS), \
+ $$(eval $$(foreach dts,$$(DEVICE_DTS) $$(DEVICE_DTS_OVERLAY), \
$$(call Device/Build/dtb,$$(notdir $$(dts)), \
$$(if $$(DEVICE_DTS_DIR),$$(DEVICE_DTS_DIR),$$(DTS_DIR)), \
$$(dts) \