summaryrefslogtreecommitdiff
path: root/include/image.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-09-01 04:08:47 +0100
committerDaniel Golle <daniel@makrotopia.org>2020-09-01 04:10:41 +0100
commit729a75c3b2db0aa25745e8db425711cc761fa1f6 (patch)
treefd6cb1c9cf5e71c06dc461b5338fba1a26203bfa /include/image.mk
parent5587f19c362a805636da91d9d550928b4a2998fc (diff)
downloadopenwrt-729a75c3b2db0aa25745e8db425711cc761fa1f6.tar.gz
build: unbreak fakeroot in SDK
Using fakeroot without passing the paths to libfakeroot.sh and faked causes havoc. Use the $(FAKEROOT) Make variable which includes them. Fixes: 353ce2e521 ("build: ipkg-build use fakeroot with PKG_FILE_MODES") Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 3a12db3676..703aeb6816 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -250,7 +250,7 @@ define Image/mkfs/squashfs
"$(call mkfs_target_dir,$(1))" > $@.fakeroot-script
echo "$(Image/mkfs/squashfs-common)" >> $@.fakeroot-script
chmod +x $@.fakeroot-script
- $(STAGING_DIR_HOST)/bin/fakeroot $@.fakeroot-script
+ $(FAKEROOT) "$@.fakeroot-script"
endef
else
define Image/mkfs/squashfs