summaryrefslogtreecommitdiff
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-03-03 16:09:04 +0100
committerFelix Fietkau <nbd@nbd.name>2021-03-03 16:09:59 +0100
commit785ab2b62c8d9366023095641f2ba237e2b0ed8e (patch)
tree40d565f4bea52d772232b4ed6cb6383a7b23e240 /include/image.mk
parent5a3562cd1da77348f8b542f8e32f75125c492474 (diff)
downloadopenwrt-785ab2b62c8d9366023095641f2ba237e2b0ed8e.tar.gz
build: use numeric uid/gid on cpio calls
There are systems that don't have the 'root' group, so don't rely on host specific user/group names Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 7f0d27b746..993de5ff53 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -301,7 +301,7 @@ endif
ifdef CONFIG_TARGET_ROOTFS_CPIOGZ
define Image/Build/cpiogz
- ( cd $(TARGET_DIR); find . | $(STAGING_DIR_HOST)/bin/cpio -o -H newc -R root:root | gzip -9n >$(BIN_DIR)/$(IMG_ROOTFS).cpio.gz )
+ ( cd $(TARGET_DIR); find . | $(STAGING_DIR_HOST)/bin/cpio -o -H newc -R 0:0 | gzip -9n >$(BIN_DIR)/$(IMG_ROOTFS).cpio.gz )
endef
endif