summaryrefslogtreecommitdiff
path: root/include/image.mk
diff options
context:
space:
mode:
authorRobert Marko <robert.marko@sartura.hr>2021-03-04 12:37:22 +0100
committerDaniel Golle <daniel@makrotopia.org>2021-03-05 15:45:33 +0000
commit9f714398e060c6338fbfad44cdbfa8c940dbb84b (patch)
tree02fb108aec8f10957ac431f545f8b3db7271392d /include/image.mk
parent5ec60cbe9d94b925393bea2a54bdaf062a28fece (diff)
downloadopenwrt-9f714398e060c6338fbfad44cdbfa8c940dbb84b.tar.gz
build: use config-1 instead of config@1 as default
U-boot will reject all nodes with @ since commit: https://gitlab.denx.de/u-boot/u-boot/-/commit/79af75f7776fc20b0d7eb6afe1e27c00fdb4b9b4 This will cause the OpenWrt images to fail booting, to rectify use the config-1 as default. Signed-off-by: Robert Marko <robert.marko@sartura.hr>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 993de5ff53..cae3e73438 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -139,7 +139,7 @@ endef
define Image/BuildKernel/MkFIT
$(TOPDIR)/scripts/mkits.sh \
-D $(1) -o $(KDIR)/fit-$(1).its -k $(2) $(if $(3),-d $(3)) -C $(4) -a $(5) -e $(6) \
- -c $(if $(DEVICE_DTS_CONFIG),$(DEVICE_DTS_CONFIG),"config@1") \
+ -c $(if $(DEVICE_DTS_CONFIG),$(DEVICE_DTS_CONFIG),"config-1") \
-A $(LINUX_KARCH) -v $(LINUX_VERSION)
PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $(KDIR)/fit-$(1).its $(KDIR)/fit-$(1)$(7).itb
endef