summaryrefslogtreecommitdiff
path: root/include/image.mk
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2022-03-27 23:15:48 +0200
committerDavid Bauer <mail@david-bauer.net>2022-10-14 23:13:02 +0200
commita01d23e755ba46f41e667d558d82d4871d7f5450 (patch)
tree77ec01f9d4006f0aecfff03f9dbea6a31f8b54f9 /include/image.mk
parent2fa53c9214b7b93fd82ad1ff885145b9e1c1f71b (diff)
downloadopenwrt-a01d23e755ba46f41e667d558d82d4871d7f5450.tar.gz
image: always rebuild kernel loaders
Kernel loaders like the lzma-loader currently don't track changes to their sources. This can lead to an old version of a loader to be used when a build tree is not clean between builds. As the loaders are tiny and the build times are insignificant, simply force rebuilding them on every build to avoid this problem. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 9e4e999581..b3dfc9019a 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -517,7 +517,7 @@ endif
define Device/Build/compile
$$(_COMPILE_TARGET): $(KDIR)/$(1)
$(eval $(call Device/Export,$(KDIR)/$(1)))
- $(KDIR)/$(1):
+ $(KDIR)/$(1): FORCE
$$(call concat_cmd,$(COMPILE/$(1)))
endef