summaryrefslogtreecommitdiff
path: root/include/image.mk
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-02-06 23:28:14 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-02-20 07:34:07 +0100
commita33b97dcb1bd6e68f01c571e92ef02c3ab721523 (patch)
tree2c7c80ce123e9c9c8343c7c03c5e64d7435a7cce /include/image.mk
parent30f2d516ba7be08f06f7ca8767472c3ea5678706 (diff)
downloadopenwrt-a33b97dcb1bd6e68f01c571e92ef02c3ab721523.tar.gz
image: update LZMA_XZ_OPTIONS with new squashfs4 tool
The -Xpreset option changed format and dropped the -Xe and just require the extreme string to be passed to the -Xpreset option. Update the LZMA_XZ_OPTIONS to reflect this change. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index b801ef993c..ef242db96e 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -77,7 +77,7 @@ SQUASHFSOPT := -b $(SQUASHFS_BLOCKSIZE)
SQUASHFSOPT += -p '/dev d 755 0 0' -p '/dev/console c 600 0 0 5 1'
SQUASHFSOPT += $(if $(CONFIG_SELINUX),-xattrs,-no-xattrs)
SQUASHFSCOMP := gzip
-LZMA_XZ_OPTIONS := -Xpreset 9 -Xe -Xlc 0 -Xlp 2 -Xpb 2
+LZMA_XZ_OPTIONS := -Xpreset extreme -Xlc 0 -Xlp 2 -Xpb 2
ifeq ($(CONFIG_SQUASHFS_XZ),y)
ifneq ($(filter arm x86 powerpc sparc,$(LINUX_KARCH)),)
BCJ_FILTER:=-Xbcj $(LINUX_KARCH)