summaryrefslogtreecommitdiff
path: root/include/image.mk
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-12-13 14:36:17 -1000
committerPaul Spooren <mail@aparcar.org>2020-12-13 22:07:52 -1000
commitbc0ffff36a0bd8043e958913f574cb8d2a79e93d (patch)
tree30b8ebb61f20bab5daf73e532a489785d49bbd64 /include/image.mk
parentcdc8d4b46f0811292fffc6094acd81e854b5f4a5 (diff)
downloadopenwrt-bc0ffff36a0bd8043e958913f574cb8d2a79e93d.tar.gz
build/json: add filesystem information
Some images are created using different filesystems, most popular squashfs and ext4. To allow downstream projects to distinguesh between those, add the `filesystem` information to created json files. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 4e7c31e8dc..8f46c75ffe 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -568,6 +568,7 @@ define Device/Build/image
SOURCE_DATE_EPOCH=$(SOURCE_DATE_EPOCH) \
IMAGE_NAME="$(IMAGE_NAME)" \
IMAGE_TYPE=$(word 1,$(subst ., ,$(2))) \
+ IMAGE_FILESYSTEM="$(1)" \
IMAGE_PREFIX="$(IMAGE_PREFIX)" \
DEVICE_VENDOR="$(DEVICE_VENDOR)" \
DEVICE_MODEL="$(DEVICE_MODEL)" \