summaryrefslogtreecommitdiff
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-10-24 16:59:15 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2017-10-24 16:59:15 -0700
commit474391573bbd9720a58b6fcd725896f85113e4ec (patch)
treec20b5b5b981aeaa0724bef629ec4572790963560 /include/kernel.mk
parentbb71847da5a1b69a3080c580ba104276c432a334 (diff)
downloadopenwrt-474391573bbd9720a58b6fcd725896f85113e4ec.tar.gz
include: Silence external kernel version checks
During the initial configuration phases, we have not set-up the kernel source directory, which would lead to such messages: cat: /local/users/fainelli/openwrt/trunk/build_dir/target-x86_64_musl/linux-uml/linux-4.9.58/include/config/kernel.release: No such file or directory Just silence it, since it does not create a functional problem. Fixes: 8e0e0e7d8bfb ("include: Determine MODULES_DIR correctly for external/git kernels") Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index a84c755a06..75797cf17e 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -64,7 +64,7 @@ else
ifeq ($(call qstrip,$(CONFIG_EXTERNAL_KERNEL_TREE))$(call qstrip,$(CONFIG_KERNEL_GIT_CLONE_URI)),)
LINUX_SITE:=@KERNEL/linux/kernel/v$(word 1,$(subst ., ,$(KERNEL_BASE))).x$(TESTING)
else
- LINUX_UNAME_VERSION:=$(strip $(shell cat $(LINUX_DIR)/include/config/kernel.release))
+ LINUX_UNAME_VERSION:=$(strip $(shell cat $(LINUX_DIR)/include/config/kernel.release 2>/dev/null))
endif
MODULES_SUBDIR:=lib/modules/$(LINUX_UNAME_VERSION)