summaryrefslogtreecommitdiff
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-11-17 22:55:03 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-12-16 22:15:23 +0100
commit5c944d95ecc3c0f0e1d0f33d18574c1b7d29f6dd (patch)
tree270dbe736f74e04d71577f7ec2f3f915a0e34d0d /include/kernel.mk
parent712e1b36f4b9ebcdd5bd0042f3ba14361632a2a7 (diff)
downloadopenwrt-5c944d95ecc3c0f0e1d0f33d18574c1b7d29f6dd.tar.gz
kernel: include: remove last .0 from kernel versions again
Kernel 4.14 has the version number 4.14 and not 4.14.0. This was different in some older Linux kernel versions, This change makes it possible to use kernel 4.14 without any minor version. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 8cb0defcb5..1b6006a62d 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -52,7 +52,7 @@ else
LINUX_VERMAGIC:=$(strip $(shell cat $(LINUX_DIR)/.vermagic 2>/dev/null))
LINUX_VERMAGIC:=$(if $(LINUX_VERMAGIC),$(LINUX_VERMAGIC),unknown)
- LINUX_UNAME_VERSION:=$(if $(word 3,$(subst ., ,$(KERNEL_BASE))),$(KERNEL_BASE),$(KERNEL_BASE).0)
+ LINUX_UNAME_VERSION:=$(KERNEL_BASE)
ifneq ($(findstring -rc,$(LINUX_VERSION)),)
LINUX_UNAME_VERSION:=$(LINUX_UNAME_VERSION)-$(strip $(lastword $(subst -, ,$(LINUX_VERSION))))
endif