summaryrefslogtreecommitdiff
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2019-10-02 12:53:09 +0200
committerFelix Fietkau <nbd@nbd.name>2019-10-02 12:55:40 +0200
commit5f8e5872406dad4df254c26a4166c58de44901ad (patch)
tree340c168ad95d79029a60225bb17f117d28c16364 /include/kernel.mk
parent0714a11bee24e5995da25ca9e0b2ae4b9f163408 (diff)
downloadopenwrt-5f8e5872406dad4df254c26a4166c58de44901ad.tar.gz
build: force disable stack validation during kernel build on non-linux systems
The check for libelf in the kernel build is not enough, because the code that uses libelf for stack validation is completely non-portable, as it tries to include asm/types.h and relies on kernel types in user space. Until this is fixed properly, the only solution is to disable this on any non Linux build host Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 97d23661c9..73645330fe 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -129,7 +129,8 @@ ifdef CONFIG_USE_SPARSE
KERNEL_MAKEOPTS += C=1 CHECK=$(STAGING_DIR_HOST)/bin/sparse
endif
-ifeq ($(HOST_OS),Darwin)
+ifneq ($(HOST_OS),Linux)
+ KERNEL_MAKEOPTS += CONFIG_STACK_VALIDATION=
export SKIP_STACK_VALIDATION:=1
endif