summaryrefslogtreecommitdiff
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-05-11 14:33:43 -0700
committerJohn Crispin <john@phrozen.org>2017-05-25 09:22:43 +0200
commit8e0e0e7d8bfbe7befcaa453f0b4993605703a690 (patch)
treeb74f64f11240d2c40f6bb0c949e336cc5c011004 /include/kernel.mk
parentb6746a6ffb738d541b64eb4107e688d36ff86417 (diff)
downloadopenwrt-8e0e0e7d8bfbe7befcaa453f0b4993605703a690.tar.gz
include: Determine MODULES_DIR correctly for external/git kernels
When using external or git cloned kernels, any kind of modifications will alter KERNELRELEASE. LEDE still tries to stage modules in lib/modules/$(LINUX_UNAME_VERSION) and LINUX_UNAME_VERSION is based on KERNEL_PATCHVER (indirectly) so this does not work, and we lose all kinds of automatic modules loading. To remedy that, just cat $(LINUX_DIR)/include/config/kernel.release which is late enough the kernel has prepared this file, and is correctly tracking changes done throughout the kernel. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 2314ec73aa..7effca3832 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -51,17 +51,19 @@ else
LINUX_UNAME_VERSION:=$(LINUX_UNAME_VERSION)-$(strip $(lastword $(subst -, ,$(LINUX_VERSION))))
endif
- MODULES_SUBDIR:=lib/modules/$(LINUX_UNAME_VERSION)
- TARGET_MODULES_DIR := $(LINUX_TARGET_DIR)/$(MODULES_SUBDIR)
-
LINUX_KERNEL:=$(KERNEL_BUILD_DIR)/vmlinux
LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.xz
TESTING:=$(if $(findstring -rc,$(LINUX_VERSION)),/testing,)
ifeq ($(call qstrip,$(CONFIG_EXTERNAL_KERNEL_TREE))$(call qstrip,$(CONFIG_KERNEL_GIT_CLONE_URI)),)
LINUX_SITE:=@KERNEL/linux/kernel/v$(word 1,$(subst ., ,$(KERNEL_BASE))).x$(TESTING)
+ else
+ LINUX_UNAME_VERSION:=$(strip $(shell cat $(LINUX_DIR)/include/config/kernel.release))
endif
+ MODULES_SUBDIR:=lib/modules/$(LINUX_UNAME_VERSION)
+ TARGET_MODULES_DIR:=$(LINUX_TARGET_DIR)/$(MODULES_SUBDIR)
+
ifneq ($(TARGET_BUILD),1)
PKG_BUILD_DIR ?= $(KERNEL_BUILD_DIR)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
endif