summaryrefslogtreecommitdiff
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2019-02-28 16:37:41 +0100
committerAlexander Couzens <lynxis@fe80.eu>2019-02-28 17:57:30 +0100
commitba3690c90c9717871ec71b24d22d9da2f283762f (patch)
tree6acc570d449f56b56b2e0f5ab7277706bfb2ced2 /include/kernel.mk
parent994428f3950c70bc92e5e6b68e784d8d660ca4ea (diff)
downloadopenwrt-ba3690c90c9717871ec71b24d22d9da2f283762f.tar.gz
include/kernel: sort autoload modules list to fix reproducible builds
When autoloading more than one modules per packages, /etc/modules.d/$module depends on the file system ordering. To test this: use disorderfs on the build_dir and build kmod-sched. Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 19ecf4fa9a..3195090a0a 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -243,7 +243,7 @@ $(call KernelPackage/$(1)/config)
exit 1; \
fi; \
done;
- $(call ModuleAutoLoad,$(1),$$(1),$(filter-out 0-,$(word 1,$(AUTOLOAD))-),$(filter-out 0,$(word 2,$(AUTOLOAD))),$(wordlist 3,99,$(AUTOLOAD)))
+ $(call ModuleAutoLoad,$(1),$$(1),$(filter-out 0-,$(word 1,$(AUTOLOAD))-),$(filter-out 0,$(word 2,$(AUTOLOAD))),$(sort $(wordlist 3,99,$(AUTOLOAD))))
$(call KernelPackage/$(1)/install,$$(1))
endef
$(if $(CONFIG_PACKAGE_kmod-$(1)),