summaryrefslogtreecommitdiff
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2019-07-03 13:29:13 +0200
committerFelix Fietkau <nbd@nbd.name>2019-07-03 14:07:59 +0200
commitc3e31b6a9b040912be0b532f9bf29d91c6c74382 (patch)
tree0ddd0a01dde21d988383e54c97318555258c8082 /include/kernel.mk
parent030d3f48e56d3a141b98a293bb3cb5b8a9ef956d (diff)
downloadopenwrt-c3e31b6a9b040912be0b532f9bf29d91c6c74382.tar.gz
build: skip kernel stack validation when building on macOS
Since we switched to 4.19, the kernel build checks for libelf to decide if it should build tools for stack validation. On macOS, this check fails during target/compile, but succeeds during package build (because of the pkg-config path picking up target libraries). Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 8dfe903bcc..975cf455c4 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -129,6 +129,10 @@ ifdef CONFIG_USE_SPARSE
KERNEL_MAKEOPTS += C=1 CHECK=$(STAGING_DIR_HOST)/bin/sparse
endif
+ifeq ($(HOST_OS),Darwin)
+ export SKIP_STACK_VALIDATION:=1
+endif
+
PKG_EXTMOD_SUBDIRS ?= .
define populate_module_symvers