summaryrefslogtreecommitdiff
path: root/include/prereq.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-04-05 13:54:41 +0200
committerJo-Philipp Wich <jo@mein.io>2018-04-05 13:58:15 +0200
commite9eb9393f4e632338d72d62512a2f74272bd8528 (patch)
treeaae7d8a7d2a16d32037731cbe9b074679d5f1265 /include/prereq.mk
parent2b84f95f382f3e1043d17b541d6b1f6278861ad7 (diff)
downloadopenwrt-e9eb9393f4e632338d72d62512a2f74272bd8528.tar.gz
include: extend SetupHostCommand macro to accept more arguments
Commit d6d3db0543 added more gcc version probes, exceeding the argument limit of the SetupHostCommand macro, leading to failing GCC/LLVM tests on OS X. Extend the handled number of arguments to restore proper functionality. Fixes FS#1470 Fixes d6d3db0543 ("build: Improve GCC version detection") Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'include/prereq.mk')
-rw-r--r--include/prereq.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/prereq.mk b/include/prereq.mk
index 6cb590e360..0f0f253744 100644
--- a/include/prereq.mk
+++ b/include/prereq.mk
@@ -90,7 +90,8 @@ define SetupHostCommand
for cmd in $(call QuoteHostCommand,$(3)) $(call QuoteHostCommand,$(4)) \
$(call QuoteHostCommand,$(5)) $(call QuoteHostCommand,$(6)) \
$(call QuoteHostCommand,$(7)) $(call QuoteHostCommand,$(8)) \
- $(call QuoteHostCommand,$(9)); do \
+ $(call QuoteHostCommand,$(9)) $(call QuoteHostCommand,$(10)) \
+ $(call QuoteHostCommand,$(11)) $(call QuoteHostCommand,$(12)); do \
if [ -n "$$$$$$$$cmd" ]; then \
bin="$$$$$$$$(PATH="$(subst $(space),:,$(filter-out $(STAGING_DIR_HOST)/%,$(subst :,$(space),$(PATH))))" \
which "$$$$$$$${cmd%% *}")"; \