summaryrefslogtreecommitdiff
path: root/include/rootfs.mk
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2018-01-28 09:43:30 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2018-01-28 09:51:06 +0800
commit60ad837bea4a006a54fd8b659083f7bf648da781 (patch)
treeb5923487377a9e4f0453ad7d241631da1a279913 /include/rootfs.mk
parent53f62bc5e5c36c1a08e162d8b26de7d831fc36e5 (diff)
downloadopenwrt-60ad837bea4a006a54fd8b659083f7bf648da781.tar.gz
procd: fix procd_lock() when prepare_roofs
This fixes the following errors when doing "make package/install" /home/yousong/git-repo/lede-project/lede/build_dir/target-mips_24kc_musl/root-malta/lib/functions/procd.sh: line 47: /home/yousong/git-repo/l ede-project/lede/build_dir/target-mips_24kc_musl/root-malta/var/lock/procd_urandom_seed.lock: No such file or directory flock: 1000: Bad file descriptor Fixes FS#1260 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'include/rootfs.mk')
-rw-r--r--include/rootfs.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/rootfs.mk b/include/rootfs.mk
index 74785cbbd3..1844f849e2 100644
--- a/include/rootfs.mk
+++ b/include/rootfs.mk
@@ -60,6 +60,7 @@ define prepare_rootfs
$(call file_copy,$(TOPDIR)/files/.,$(1)); \
fi
@mkdir -p $(1)/etc/rc.d
+ @mkdir -p $(1)/var/lock
@( \
cd $(1); \
for script in ./usr/lib/opkg/info/*.postinst; do \
@@ -84,6 +85,7 @@ define prepare_rootfs
rm -f $(1)/usr/lib/opkg/lists/*
rm -f $(1)/usr/lib/opkg/info/*.postinst*
rm -f $(1)/usr/lib/opkg/info/*.prerm*
+ rm -f $(1)/var/lock/*.lock
$(call clean_ipkg,$(1))
$(call mklibs,$(1))
endef