summaryrefslogtreecommitdiff
path: root/include/rootfs.mk
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2017-01-24 17:00:43 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2017-01-24 17:18:36 +0100
commit7e1fc09c4f2cc1656f315abaf6d3ba0eb11aa3fa (patch)
tree859dbaf45be9b4ff9aa844569efe51175a910533 /include/rootfs.mk
parent4376e69473ef6df7ecef0996947ade588c5e8504 (diff)
downloadopenwrt-7e1fc09c4f2cc1656f315abaf6d3ba0eb11aa3fa.tar.gz
include/rootfs.mk: keep Require-User lines with CONFIG_CLEAN_IPKG
Require-User is handled by /etc/uci-defaults/13_fix_group_user on first boot, so we need to keep these when removing all opkg data with CONFIG_CLEAN_IPKG. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'include/rootfs.mk')
-rw-r--r--include/rootfs.mk10
1 files changed, 9 insertions, 1 deletions
diff --git a/include/rootfs.mk b/include/rootfs.mk
index 90d70a11f2..c014b1d14a 100644
--- a/include/rootfs.mk
+++ b/include/rootfs.mk
@@ -47,6 +47,14 @@ opkg = \
TARGET_DIR_ORIG := $(TARGET_ROOTFS_DIR)/root.orig-$(BOARD)
+ifdef CONFIG_CLEAN_IPKG
+ define clean_ipkg
+ -find $(1)/usr/lib/opkg -type f -and -not -name '*.control' | $(XARGS) rm -rf
+ -sed -i -ne '/^Require-User: /p' $(1)/usr/lib/opkg/info/*.control
+ -find $(1)/usr/lib/opkg -empty | $(XARGS) rm -rf
+ endef
+endif
+
define prepare_rootfs
@if [ -d $(TOPDIR)/files ]; then \
$(call file_copy,$(TOPDIR)/files/.,$(1)); \
@@ -75,6 +83,6 @@ define prepare_rootfs
rm -f $(1)/usr/lib/opkg/lists/*
rm -f $(1)/usr/lib/opkg/info/*.postinst*
rm -f $(1)/usr/lib/opkg/info/*.prerm*
- $(if $(CONFIG_CLEAN_IPKG),rm -rf $(1)/usr/lib/opkg)
+ $(call clean_ipkg,$(1))
$(call mklibs,$(1))
endef