summaryrefslogtreecommitdiff
path: root/include/rootfs.mk
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2019-09-20 05:36:13 +0200
committerAlexander Couzens <lynxis@fe80.eu>2019-09-21 03:26:38 +0200
commit8cb13f4e6d5750957449b4c5740f64af11a9ad36 (patch)
tree585628d41ed470539f04fe208f90c2acf688e1e0 /include/rootfs.mk
parent81e93fff7d867851f2fedd966a931336d4092686 (diff)
downloadopenwrt-8cb13f4e6d5750957449b4c5740f64af11a9ad36.tar.gz
rootfs.mk: ensure all timestamp are set to SOURCE_DATE_EPOCH
Some tools doesn't support SOURCE_DATE_EPOCH (e.g. initramfs images). Ensure all files of a root filesystem are set to SOURCE_DATE_EPOCH. Make initramfs builds reproducible (for ramips). Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'include/rootfs.mk')
-rw-r--r--include/rootfs.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/rootfs.mk b/include/rootfs.mk
index f2d2494ae2..b6775c7e15 100644
--- a/include/rootfs.mk
+++ b/include/rootfs.mk
@@ -99,4 +99,5 @@ define prepare_rootfs
rm -rf $(1)/boot
$(call clean_ipkg,$(1))
$(call mklibs,$(1))
+ $(if $(SOURCE_DATE_EPOCH),find $(1)/ -mindepth 1 -execdir touch -hcd "@$(SOURCE_DATE_EPOCH)" "{}" +)
endef