summaryrefslogtreecommitdiff
path: root/include/target.mk
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2020-08-13 22:11:22 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2020-10-11 16:16:24 +0200
commit1b27591ddbdd2d359ea6771fa878c8562be98fc5 (patch)
tree34f1d1349920134e3a347610352dd7a30b11999c /include/target.mk
parent9f9243887e4aca106f9c9ad09632734662728f92 (diff)
downloadopenwrt-1b27591ddbdd2d359ea6771fa878c8562be98fc5.tar.gz
malta: update MIPS64 ISA to R2
Usage of current R1 ISA is inconsistent with the MIPS32 subtarget, little used and has limited utility for testing. Many distros target a minimum R2 ISA. Debian MIPS 32-bit/64-bit ports all use MIPS R2 ISA since Stretch, for example. Fedora's MIPS arch also targets the R2 ISA for 32-bit/64-bit. Widely used MIPS64 platforms like Octeon are based on the MIPS R2 ISA or later, and benefit from having a compatible test platform in OpenWRT. While Linux does support MIPS64 R1 targets, its usefulness for development and testing is limited. As an example, the modern Linux eBPF JIT requires a MIPS R2 ISA or later. Signed-off-by: Tony Ambardar <itugrok@yahoo.com> [Refresh config and fix README] Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index 93c1c42552..d593a5f0df 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -198,6 +198,7 @@ ifeq ($(DUMP),1)
CPU_CFLAGS += -mno-branch-likely
CPU_CFLAGS_mips32 = -mips32 -mtune=mips32
CPU_CFLAGS_mips64 = -mips64 -mtune=mips64 -mabi=64
+ CPU_CFLAGS_mips64r2 = -mips64r2 -mtune=mips64r2 -mabi=64
CPU_CFLAGS_24kc = -mips32r2 -mtune=24kc
CPU_CFLAGS_74kc = -mips32r2 -mtune=74kc
CPU_CFLAGS_octeonplus = -march=octeon+ -mabi=64