summaryrefslogtreecommitdiff
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2022-09-27 13:39:12 +0200
committerFelix Fietkau <nbd@nbd.name>2022-09-27 13:41:12 +0200
commit3a8825ad6acbf18b2b472ace56be58868af78be7 (patch)
treeaca639577b15e1dac7a6ca86ad1152e29d57c5c1 /include/target.mk
parentf1b3958d02ba8b8a8bf2182599653ddd553906a8 (diff)
downloadopenwrt-3a8825ad6acbf18b2b472ace56be58868af78be7.tar.gz
build: fix issues with targets installed via feeds
- fix including modules.mk when a target is being replaced - fix calling make targets from target/linux Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/target.mk b/include/target.mk
index a2c8b7bdbf..708ba395c6 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -68,7 +68,7 @@ endif
target_conf=$(subst .,_,$(subst -,_,$(subst /,_,$(1))))
ifeq ($(DUMP),)
- PLATFORM_DIR:=$(TOPDIR)/target/linux/$(BOARD)
+ PLATFORM_DIR:=$(firstword $(wildcard $(TOPDIR)/target/linux/feeds/$(BOARD) $(TOPDIR)/target/linux/$(BOARD)))
SUBTARGET:=$(strip $(foreach subdir,$(patsubst $(PLATFORM_DIR)/%/target.mk,%,$(wildcard $(PLATFORM_DIR)/*/target.mk)),$(if $(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(subdir))),$(subdir))))
else
PLATFORM_DIR:=${CURDIR}