summaryrefslogtreecommitdiff
path: root/include/target.mk
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-01-11 20:44:34 -0800
committerPetr Štetiar <ynezz@true.cz>2020-07-08 22:54:34 +0200
commit691bf54369fbccf9c27a14231a14dcdf07acaf36 (patch)
treed33d72cf058583907b37707171d9c478e2b1edd8 /include/target.mk
parent3e992ea790f470d754eaba3e76608630f38055db (diff)
downloadopenwrt-691bf54369fbccf9c27a14231a14dcdf07acaf36.tar.gz
target.mk: change i386 CPU type to pentium-mmx
f4f8f4a180366ee90fd8e153213db2cb746ca361 broke ffmpeg compilation with x86 The reason is that ffmpeg's x86 assembly requires at least MMX, which the pentium CPU_TYPE was preventing. Fixes ffmpeg compilation on x86_legacy and x86_geode. Ref: https://github.com/openwrt/openwrt/pull/3061 Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/target.mk b/include/target.mk
index 64292138b7..aba477e83b 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -174,8 +174,8 @@ ifeq ($(DUMP),1)
CPU_CFLAGS_octeonplus = -march=octeon+ -mabi=64
endif
ifeq ($(ARCH),i386)
- CPU_TYPE ?= pentium
- CPU_CFLAGS_pentium = -march=pentium-mmx
+ CPU_TYPE ?= pentium-mmx
+ CPU_CFLAGS_pentium-mmx = -march=pentium-mmx
CPU_CFLAGS_pentium4 = -march=pentium4
endif
ifneq ($(findstring arm,$(ARCH)),)