summaryrefslogtreecommitdiff
path: root/include/target.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke.mehrtens@intel.com>2017-03-14 18:55:03 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-03-20 22:04:45 +0100
commit7c7ea090041dc2a5e51b36d0bc3115a8830525bf (patch)
treed0ca791eb5079a1bb1a1178f3a89fe822f6b051e /include/target.mk
parentd5a770f2c139a335e7602bec60dbeabd4add1e8b (diff)
downloadopenwrt-7c7ea090041dc2a5e51b36d0bc3115a8830525bf.tar.gz
include: Add nomips16 CPU_SUBTYPE
This can be used to indicate that a target does not support the optional mips16 extension even when it is a mips32r2 or later CPU. This will generate a separate toolchain and a separate package folder, e.g. mips_24kc_nomips16 Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/target.mk b/include/target.mk
index 5490d4882f..61489cabe7 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -258,7 +258,9 @@ ifeq ($(DUMP),1)
FEATURES += virtio
endif
ifneq ($(CONFIG_CPU_MIPS32_R2),)
- FEATURES += mips16
+ ifneq ($(CPU_SUBTYPE),nomips16)
+ FEATURES += mips16
+ endif
endif
FEATURES += $(foreach v,6 7,$(if $(CONFIG_CPU_V$(v)),arm_v$(v)))