summaryrefslogtreecommitdiff
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2019-04-27 19:13:07 +0200
committerFelix Fietkau <nbd@nbd.name>2019-05-11 11:37:10 +0200
commit85017c40f4efce11edd77e0caac14aed0fd690eb (patch)
tree016be4bb6f80dcc9ef001a1c95424b8f3fba4cea /include/target.mk
parent9cb3a3255e024183a2e179fe6621cd11fa6b8670 (diff)
downloadopenwrt-85017c40f4efce11edd77e0caac14aed0fd690eb.tar.gz
build: add a config option for enabling a testing version of the target kernel
If the target supports a newer kernel version that is not used by default yet, it can be enabled with this option Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index d24bb9cd11..4f3bd43e6c 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -225,6 +225,9 @@ ifeq ($(DUMP),1)
.SILENT: $(TMP_CONFIG)
.PRECIOUS: $(TMP_CONFIG)
+ ifdef KERNEL_TESTING_PATCHVER
+ FEATURES += testing-kernel
+ endif
ifneq ($(CONFIG_OF),)
FEATURES += dt
endif
@@ -283,6 +286,7 @@ define BuildTargets/DumpCurrent
echo 'Target-Optimization: $(if $(CFLAGS),$(CFLAGS),$(DEFAULT_CFLAGS))'; \
echo 'CPU-Type: $(CPU_TYPE)$(if $(CPU_SUBTYPE),+$(CPU_SUBTYPE))'; \
echo 'Linux-Version: $(LINUX_VERSION)'; \
+ $(if $(LINUX_TESTING_VERSION),echo 'Linux-Testing-Version: $(LINUX_TESTING_VERSION)';) \
echo 'Linux-Release: $(LINUX_RELEASE)'; \
echo 'Linux-Kernel-Arch: $(LINUX_KARCH)'; \
$(if $(SUBTARGET),,$(if $(DEFAULT_SUBTARGET), echo 'Default-Subtarget: $(DEFAULT_SUBTARGET)'; )) \